Find answers, ask questions, and connect with our
community around the world.

Forums Forums Web Design WordPress Having trouble getting FB to pull any preview images from blog post on site that uses RankMath.

  • Having trouble getting FB to pull any preview images from blog post on site that uses RankMath.

    updated 1 week ago 0 Member · 1 Post
  • SharonP

    Member
    September 23, 2022 at 3:08 pm

    I’m stuck on what to try next. I’ve disabled caching on the site. WP core, theme, and plugins are all up to date. The site uses RankMath. For some reason, the preview image FB shows when I post a blog post is blank. This is what it looks like. Blog posts are created in Gutenberg, and pulling up RankMath’s Preview Snippet Editor appears to show the correct image like this. When I try to use FB’s Sharing Debugger, the og:image shows the correct URL of the image file. When I navigate to that URL, the image shows as expected, but the Link Preview also shows as blank just like making a new post. Here is what the Sharing Debugger shows. I’m stumped on what to try next. Searching around online tends to point me towards the Sharing Debugger tool, but I’m not sure what to try after that. Thank you for taking the time to read this and I appreciate any ideas. This is affecting all of the blog posts from this site, but it’s not occurring on other sites we run that have similar plugins/theme. – by /hq/NicksIdeaEngine – –

Viewing 1 of 1 replies
Reply to: SharonP
Your information:

Cancel
Original Post
0 of 0 posts June 2018
Now