Find answers, ask questions, and connect with our
community around the world.

Forums Forums Web Design Let’s Encrypt Certbot is set to redirect http requests to https and is working for .html files, but .php files don’t redirect automatically. How do I make them automatically redirect to https?

  • Let’s Encrypt Certbot is set to redirect http requests to https and is working for .html files, but .php files don’t redirect automatically. How do I make them automatically redirect to https?

    updated 3 years, 5 months ago 0 Member · 1 Post
  • Maverick

    Member
    September 9, 2019 at 12:47 am

    I followed this guide: How To Configure Nginx as a Web Server and Reverse Proxy for Apache on One Ubuntu 18.04 Server. Everything seems to be working fine as it is covered in the tutorial, but I have noticed an issue that isn’t covered in the tutorial and I can’t seem to find an answer by searching online. When I visit http://MyDomain.tld/index.html it successfully redirects to https://MyDomain.tld/index.html automatically. But when I try http://MyDomain.tld/date.php it stays http without redirecting. It will serve https://MyDomain.tld/date.php successfully if I type the https manually but I want it to redirect it automatically. I even have the httpseverywhere addon enabled in Firefox but that isn’t redirecting it for .php pages either. Is it possible to have php pages automatically redirect to https, and if so, how? Thanks in advance for any help. *Edited to add: Also, please let me know if there is a more appropriate subhq overview I should be asking in if this is not the best place. – by hq overview STEMnet – –

Viewing 1 of 1 replies
Reply to: Maverick
Your information:

Cancel
Original Post
0 of 0 posts June 2018
Now